What is the minimum OS needed to run an Android app on my device?

In order to run the Android Magazine App on an Android / Samsung smart device, the OS version needs to be a minimum of 4.1

At this stage, we do not have a matrix detailing Android device compatibility with MagCast as there are simply too many Android devices to cover.